FriendUP HQ

Please visit the main source of project information on the FriendUP website:

Storage requirements

This topic contains 7 replies, has 4 voices, and was last updated by  mazoola 8 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #959

    Truls
    Participant

    I tried installing the FriendChat module and it filled my 20gb vps to the brim.
    Could this be misconfiguration on my end? I deployed this server today for the sole purpose of testing out FriendUP so it was empty, and there’s nothing else running on it.

    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/root 20391396 20375012 0 100% /

    #962

    Truls
    Participant

    It seems the install script had somehow gone into a loop creating redundant folders with all the same files, here’s an example of this crazy folder structure:

    /home/friendup/friendup/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/services/Presence/build/resources/webclient/js/utils

    I believe this happened when I ran the InstallFriendChat.sh script. I’m running Debian 9 on a Linode vps, I’m going to roll back and try a clean install.

    #963

    thomas
    Keymaster

    Hi Truls, sorry about that. It seems that the install script can go into an endless loop and fill up the harddisk. We are looking into the issue.

    #964

    sokken
    Participant

    Hi,

    This seems to be the script in the friendUP folder? ( as opposed to the script in the FriendChat git repo ). Was it run manually by you, or as part of the friendUP/install.sh script?

    #965

    Truls
    Participant

    I did ‘git clone https://github.com/FriendSoftwareLabs/friendup‘ 04/02. I first installed the Core and played with that a bit. I then shut down the service with the killfriend.sh and installed both the Chat and the Network modules with the scripts found in the friendup folder I cloned from GitHub.

    I did choose to ignore a warning about my version of node being out of date.
    The package I had installed from earlier was ‘nodejs’ as opposed to just node (‘node -v’ resulted in command not found as opposed ‘nodejs -v’ which did give me a version number). The script couldn’t detect my node install with the nodejs package, if I let the script install node for me it wouldn’t detect it either.

    I eventually went on to install the ‘node’ package, which allowed me run ‘node -v’ and the script ran fine, albeit with the outdated node version warning.

    I am only a student and my experience with linux is limited but maybe there’s something strange here.

    #966

    sokken
    Participant

    I havent looked at the scripts yet, but the main install.sh might be setting some environment variables for the chat install script. Thanks for the step-by-step. Doing the friendUP and chat install together should work better.

    Node is a separate issue here; it can be a bit of a kludge. nodejs is a no-go. Ive found this – ‘n’ – to be a good way of managing node: https://github.com/tj/n It handles installing and switching versions for you. Make sure to purge _all_ nodejs, node and npm things from your system first.

    #969

    mazoola
    Participant

    I’ve been struggling with the same issue under Ubuntu 16.04 on a DigitalOcean VM. Using the installation scripts from a freshly cloned repository, each attempt to install FriendChat leads into that Presence/build/services loop. Unlike Truls, though, nothing I’ve tried has managed to break me out of it. I’ve not yet isolated the loop’s entry point in the install script (my Linux is rusty, as I usually go with FreeBSD as a server OS and Windows/macOS for workstations), but I was wondering what info you’d like to see from me as I muddle through this — is there anything I can provide to assist *your* debugging efforts?

    Maz

    #970

    mazoola
    Participant

    Ignore my previous message; I had been trying to install FriendChat from a SUed admin accoount.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Comments are closed.